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Step One:

Open the photo that you want to apply
a vignette soft-edged effect to. Get the
Rectangular Marquee tool and draw a
rectangular selection just inside the bor-
ders of your image.

Step Two:

Set your Background color to white, then
go under the Select menu and choose
Feather. In the dialog, for Feather Radius
enter 10 pixels (the higher the number,
the softer your border will be), then click
OK. You'll see the borders of your selec-
tion are now rounded, indicating that a
feather has been applied. To select the
area bordering your image, go under the
Select menu and choose Inverse.

Step Three:

Now all you have to do is press Delete
(PC: Backspace) to erase the edges and
reveal the soft-edged border. Press
Command-D (PC: Control-D) to deselect
so you can see the final effect.
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Ripped Edge Effect

Step One:

Open the photo you want revealed when
you apply a ripped edge effect to an |
image above it. Then, open the image

you want to rip, and drag it on top of

your original photo with the Move tool.

Get the Lasso tool and draw a somewhat
jaggy selection where you want the rip |
(in this case, it's around the center of the
image), then press Delete (PC: Backspace)

to knock a hole out of this top layer,
revealing the layer below.

Step Two:

To add some depth, choose Outer Glow
from the Add a Layer Style pop-up menu
at the bottom of the Layers palette.

Set the Blend Mode to Normal, change
the Size to 16, click on the beige color
swatch, and change the glow color to
black in the Color Picker. Click OK to
apply a black glow inside your ripped
area. Get the Lasso tool again, and draw
another selection just outside the ripped
area. Don't exactly trace the original rip,
but loosely follow along the edge.

Step Three:
To make this slightly larger selection
look like the paper behind the rip, press ——
~ Channel: [RGB _ M —

Command-L (PC: Control-L) to bring up
Levels, then drag the bottom-left Output
Levels slider almost all the way to the
right. This lightens the selected area, |
adding more depth and interest to your
ripped effect.

input Levels:[0 |[1.00 |[255 |
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Filter Edge Effect

ﬁl‘

I\

(NN (NAT

s "I ;’}-“-. 1/ .l-']I: h, .:H -

-

| [Cldl = ][ B0 g

Sprayed Srokes (100N

» i a [ =
T £

Tan YNy Ty

St e

He

L
| T
L
g Vewten

anse

“2 Untitled-2 @ 100% (Layer 1, Quick Mask/8)

REE ——

GRrAPHIC DESIGN & COMMUNICATIONS
KEANEY

Step One:

Open the photo you want to apply a
filter edge effect to. Get the Rectangular
Marquee tool and draw a selection just
inside the borders of the image. Click on
the Quick Mask icon near the bottom of
the Toolbox (or just press the letter “q”)
to enter Quick Mask mode. Now your
selection border is hidden, and the area
outside your selection appears in red.

Step Two:

Go under the Filter menu, under Brush
Strokes, and choose Sprayed Strokes.
Set the Stroke Length to 12, the Stray
Radius to 7, and Stroke Direction to
Right Diagonal. At the bottom-right
side of the dialog, click on the New
Effect Layer icon (to the left of the
Trash icon). In the list of filters on the
left, click on the Sketch folder, and click
on the Torn Edges filter. Set the Image
Balance to 25, Smoothness to 11, and
Contrast to 18, then click OK to apply
both of these filters to the edge area.

Step Three:

Press “q” to return to Standard mode,
and you'll see your selection border reap-
pear. Now choose Select>Inverse, so the
outside area of your photo is selected.
Press “d” to set your Background color to
white, and press Delete (PC: Backspace)
to delete the area around your photo,
leaving you with the edge effect

shown here. Now deselect by pressing
Command-D (PC: Control-D) to see your
final effect.
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Painted Edge Effect

Step One:

Open the photo you want to apply the
painted edge to. Press Command-A (PC:
Control-A) to select the entire photo,
then press Shift-Command-) (PC: Shift-
Control-)) to cut the image from the
background and put it on a separate
layer. Under the Image menu, choose

Canvas Size. Check the Relative checkbox,

then enter 2 inches for both Width and
Height, and click OK.

Step Two:

Command-click (PC: Control-click) on
your photo layer in the Layers palette
to put a selection around your photo.
Then go to the Paths palette, and from
the palette’s flyout menu choose Make
Work Path and click OK. Next, get the
Brush tool, open the Brush Picker in the
Options Bar, scroll to the bottom of the
default set of brushes, and click on the
100-pixel Rough Round Bristle brush.

Step Three:

In the Layers palette, create a new layer,
then go back to the Paths palette, and
from the palette’s flyout menu choose
Stroke Path. When the dialog appears,
turn on the Simulate Pressure checkbox,
and for Tool choose Brush. Click OK,
and the path around your photo will be
stroked with your 100-pixel brush. Press
Command- (PC: Control-]) to duplicate
the layer, making the stroke darker.
Finally, drag your image layer to the top
of the layers stack so the inside edge of
the stroke will be smooth.
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Scattered Photo Collage Effect

There’s this pervasive perception among some Photoshop artists that something remarkable must take
a lot of time to create. Who said that? For instance, here we have a scattered-photo effect that could be
achieved in different time-consuming ways, but we'll show you how to get it done fast.

This is a quick-and-easy way to use shape layers and layer styles
to achieve the classic but popular effect of a single image that
looks as though it was compiled from several separate images.
Once you realize how simple and fun this technique is, you'll
want to try it on all your images.

STEP ONE: Of course, we must start with an image, so go ahead
and open whichever file you'd like to test with this effect. We're
using this party girl, courtesy of Fotolia, as our test image.

STEP TWO: Go under the Edit menu and select Define Pattern to
load the entire image as a pattern. “Huh,"you ask? Don't worry, this
will make sense in a minute and it will make things a lot easier for
us later on.

YURI ARCURS

STEP THREE: Click the Create a
New Layer icon at the bottom of
the Layers panel to make a new
blank layer and then press Shift-
Delete (PC: Shift-Backspace) to
open the Fill dialog. Select Black
from the Use menu and click OK.

v
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STEP FOUR: G S G
: Go over to the Toolbox and select the Rectangle RS
tool (U). Up in the Options Bar, make sure the Shape Layers icon _ ‘. \ ;um,. Shape Tool
is active—it's the first icon at the far left—rather than Paths or -;kﬁ- -
Fill Pixels. &
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Shape layers i ——-

Then look over to the far right on the Options Bar and you'll L:"” _ 5
see a Color swatch. Click on it to open the Color Picker dialog, R o
choose a gray color for the fill (we used R:146, G:148, B:151), and | =
click OK. \’:“l"‘""‘

= . st
STEP FIVE: Now go over to the canvas window draw a small
horizontal box. In the Layers panel, you'll see that it automati- o, Fecaey &

cally creates a new shape layer. This will be the base shape for |
the presumed snapshots we'll create.
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STEP SIX: Click the Add a Layer Style (fx) icon at the bottom of EsasaesanlayerStyle —_
the Layers panel and choose Stroke from the menu. Set the Size Stroke

to 3 px and choose Inside from the Position menu. Click the swatch S

next to Color toward the bottom of the dialog, set the color to F e & .
white (R:255, G:255, B:255) when the Color Picker dialog appears, et ote (e — »

and click OK. This will give our box a simple border.

Opacity 100 |
Don't click OK just yet because we need to add another
layer style. Fill Type: [ Color g}
Color

STEP SEVEN: Activate Pattern Overlay next by clicking on its

name in the Styles list at the left of the dialog. Click the Pattern SRR

thumbnail to open the pattern library. Locate the defined image Pattern

we created in Step Two—it should be the last one in the menu— Blend Mode: { Normal 3]

and click on it. Uncheck the Link with Layer option and click the Opacity T
Snap to Origin button. This will lock the pattern in its original 5 Vs
position no matter where we place the shape on the layer. Now, T ) i [ ( SraproOngin |
click OK to close the Layer Style dialog. e iy

1 Link with Layer Y

STEP EIGHT: Press
Command-T (PC:
Ctrl-T) to invoke
the Free Transform
bounding box.
Control-click (PC:
Right-click) on the
object, choose
Rotate from the
pop-up menu,
and rotate the object just a little bit. Press Return (PC: Enter) to
commit the transformation.

STEP NINE: Now hold down the Command-Option (PC: Ctrl-Alt)
keys and then click-and-drag out a duplicate of this layer. Again
press Command-T (PC: Ctrl-T) and rotate the object differently
from the previous one and commit this transformation. You'll
notice the image revealing itself through the photos.

STEP TEN: Continue copying, rotating, and arranging the shape
layers that contain our two simple layer style treatments until
you get something that's visually captivating.

Once you have all your shape layers in place, change Layer 1's
color: Open the Fill dialog again, select Color from the Use menu,
choose a color that complements the rest of the image, and
click OK twice.

See how easy and fast that was? And how using this technique
enables us to make the subject really pop? Continue working
with your images to see which ones might truly benefit from this
technique. Tip: If you change your Background layer into a smart
object (Layer>Smart Objects>Convert to Smart Object), you can
easily try several images in a limited amount of time. Enjoy! Bl




Quick Polaroid® Effect
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Step One:

Open the photo you want to apply the
Polaroid® effect to. Press Command-A
(PC: Control-A) to select the entire
photo, then press Shift-Command-) (PC:
Shift-Control-)) to cut the image from
the background and put it on a separate
layer. Now go under the Image menu and
choose Canvas Size. Check the Relative
checkbox, then for Width and Height
enter 2 inches, and click OK to add 2
inches of white space around your photo.

Step Two:

Choose Stroke from the Add a Layer
Style pop-up menu at the bottom of the
Layers palette. When the dialog appears,
click on the red Color swatch and choose
a very, very light gray color as your
stroke. Set your Position to Inside, so the
stroke has pointy corners, then increase
the Size to 15 or more to make your bor-
der. Don't click OK yet.

Step Three:

In the Styles list on the left side of

the dialog, click directly on the words
“Drop Shadow.” In the dialog, increase
the Size setting to around 13, which
softens the shadow and makes it a

bit larger. Click OK to apply both the
stroke and drop shadow effects to
complete the technique.
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Down & Dirty Tricks

The hottest new Photoshop tricks and coolest special effects

MmBY COREY BARKER

Custom Picture Frames

This technique is another example of using Photoshop tools in a very unusual way. Once you're aware
of what a filter can do, the possibilities present themselves. We're going to create a molded picture

frame from scratch using the Lighting Effects filter.

STEP ONE: Choose File>New to create a new RGB document

that's 7x7" at 200 ppi. Click the Create a New Layer icon at the
bottom of the Layers panel, then press Shift-Delete (PC: Shift-
Backspace). In the Fill dialog, choose 50% Gray from the Use

menu, and click OK.

STEP TWO: Press Command-A to select the entire area of the

document. Then go under the Select menu and choose Trans-
form Selection. In the Options Bar click the Maintain Aspect

Ratio icon (link icon) to constrain the proportions of the selec-
tion, then enter 75% for the Width and the Height will change

to 75% also. Press Return (PC: Enter) twice. With the selection

resized, press Delete (PC: Backspace) to knock out the center,

leaving you with the base frame.

STEP THREE: Click the Create a New Layer icon at the bottom of
the Layers panel to create a new blank layer above this frame
layer (Layer 2). Press Command-R (PC: Ctrl-R) to open the rulers
(if they're not already open). Now drag a guide from the horizon-
tal ruler down to the center of the document. It should snap dead
center. Do the same with a vertical guide. Once the guides are in
place, grab the Rectangular Marquee tool (M) from the Toolbox,
and drag out a selection starting at the top-left of the document
and release once you reach the center (as shown here). Again, the
selection should snap to the edges of the guides.

Fill

— Contents ————— = |
| use:[ 50% Gray E
} e ( Cancel )
| Custom Pattern r
Blending o DT
Mode: | Normal . E |

Opacity: |100 | % |
[ Preserve Transparency ‘




STEP FOUR: Press the D key to ensure your Foreground and
Background color swatches are set to their default colors. Hold
down the Option (PC: Alt) key, go under the Filter menu, under
Render, and select Clouds. (Holding down the Option [PC: Alt]
key renders clouds with more contrast.)

STEP FIVE: Command-click (PC: Ctrl-click) on the frame layer
thumbnail (Layer 1) to load it as a selection, then press Shift-
Command-| (PC: Shift-Ctrl-l) to invert the selection. Make sure
the cloud layer is still selected and press Delete (PC: Backspace).
The result should be the clouds contained within that frame
shape. Press Command-D (PC: Ctrl-D) to deselect.

STEP SIX: Grab the Smudge tool (nested under the Blur tool)
from the Toolbox. Choose a round, soft-edged brush at around
30 px and, in the Options Bar, set the Strength to 75%. Now ran-
domly smudge the clouds on the layer. Don't worry if it runs off
as you see here. Just smear in an artistic way, not a chaotic way.
Keep working it until you get an arrangement similar to this,

STEP SEVEN: Now we'll make a symmetrical frame from this one
corner piece. Press Command-J (PC: Ctrl-J) to create a duplicate
of this layer (Layer 2 copy). Go under the Edit menu, under
Transform, and select Flip Horizontal. Select the Move tool (V),
nd drag this layer over until it snaps to the top and right edges.
Change the layer blend mode to Hard Light.
Following the steps above, create a duplicate of this layer

Layer 2 copy 2), but this time flip it vertically and drag it down
until it snaps in place at the bottom right. Create one more dupli-
cate of this layer (Layer 2 copy 3), flip it horizontally, and drag it to
the left edge. You should have all four sides covered (as shown).




to select them, and press Command-E (PC: Ctrl-E) to merge them

STEP EIGHT: In the Layers panel, Shift-click all four of these layers w
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STEP NINE: Command
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CHANNELS |

this newly merged layer’s D RGE "2

thumbnail to load it as a e

selection. Go under the Edit Rad =
menu and choose Copy.

Open the Channels panel orra =

(Windows>Channels) and I

click the Create New Chan- | s i

nel icon at the bottom of " :-;lml e ;5 ;

the panel to create a new

alpha channel (Alpha 1).Go | g ) 3 i

under the Edit menu once

more and choose Paste.

STEP TEN: Return to the Layers panel, click the Eye icon for Layer 2 e Uightiog fflecia

copy 3 to hide it, and select the frame layer we created earlier g L ==

(Layer 1). Go under the Filter menu, under Render, and choose
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STEP ELEVEN: Command-click (PC: Ctrl-click) the Create a New
Layer icon to place a new layer beneath the current frame layer
(Layer 2). With this new layer active, Command-click (PC: Ctrl-
click) the Layer 1 thumbnail to load it as a selection.

Open the Swatches panel (Window>Swatches) and choose
a color. We wanted a more gold color so the frame would look
old-fashioned. With the color selected, press Option-Delete
(PC: Alt-Backspace) to fill the selection. (Note: Look at the Layer 2
thumbnail to see the fill.)

STEP TWELVE: Select Layer 1 and change the blend mode to
Overlay. This will blend the texture with the color, completing
the effect. Now you can apply the lighting effects directly to the
colored framed. | do it this way because if | decide to change
the color of the frame, all | need to do is fill that layer with a new
color, leaving the texture layer untouched. (Note: If the frame
doesn't appear when you change the blend mode, the color on
Layer 2 is too light, so try a darker color.)

Finally, we just added an inset black matte and a photo to com-
plete the overall look. Here are a couple of examples. Enjoy. l
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Check out more Photoshop tutorials
at these websites:

www.planetphotoshop.com
www.photoshopcafe.com
www.layersmagazine.com

www.adobe.com/designcenter
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